Welcome to TATSH.

In order to access the application, you need to use Internet Explorer 5 (or later version), and enable the following security settings (Menu Tools.Internet Options, "Security" tab, "Custom Level" button):

If your IE settings are correct, you are welcome to proceed further:

Your Local Territory

       

New Login







Copyright NEXtCARE 1999-2013